Winstep

Software Technologies


 Winstep Forums


Print view
Board index : Winstep Forums : General Discussion  [ 13 posts ]
Author Message
 Post subject: Odd Focus Toggle Problem
PostPosted: Mon Jun 11, 2018 4:43 pm 
Offline
User avatar

Joined: Wed Mar 28, 2018 10:20 pm
Posts: 9
Location: Planet Earth
I love the new focus toggle! Thank you so much for including this setting. It works great on one shelf and two docks, but causes a problem on my third dock.

If I go to Nexus/Preferences/Docks & Shelves/Properties/Behavior/Activation Settings and disable "Grab focus when activated" it no longer shows the dock when I do an edge bump. If I enable "grab focus," edge bump works again.

I've attempted to duplicate and simply delete and create a new dock, but the problem remains. Weird, yes?

_________________
"There's no such thing as a foolproof system. Someone will make a better fool, tomorrow." —LoneWolffe


Back to top
 Profile WWW 
 
 Post subject: Re: Odd Focus Toggle Problem
PostPosted: Mon Jun 11, 2018 5:08 pm 
Offline
Site Admin
User avatar

Joined: Thu Feb 26, 2004 8:30 pm
Posts: 9867
Weird indeed. Must be a combination of settings unique to that dock?

What happens if you assign an hotkey to the offending dock and try to activate it using that method?

_________________
Jorge Coelho
Winstep Xtreme - Xtreme Power!
http://www.winstep.net - Winstep Software Technologies


Back to top
 Profile WWW 
 
 Post subject: Re: Odd Focus Toggle Problem
PostPosted: Mon Jun 11, 2018 5:36 pm 
Offline
User avatar

Joined: Wed Mar 28, 2018 10:20 pm
Posts: 9
Location: Planet Earth
The only thing that's different about this dock is that it's only for my system tray. Otherwise, same theme, effects, and activation settings are all the same.

I tried setting a different hotkey, this time using Ctrl+Shift+0 instead of Bump Right Screen Edge, but it's the same problem. If "Grab focus" is disabled, the dock will not activate.


Attachments:
SS.1528738739.png
SS.1528738739.png [ 148.79 KiB | Viewed 1561 times ]

_________________
"There's no such thing as a foolproof system. Someone will make a better fool, tomorrow." —LoneWolffe
Back to top
 Profile WWW 
 
 Post subject: Re: Odd Focus Toggle Problem
PostPosted: Mon Jun 11, 2018 6:10 pm 
Offline
Site Admin
User avatar

Joined: Thu Feb 26, 2004 8:30 pm
Posts: 9867
bnjroo wrote:
The only thing that's different about this dock is that it's only for my system tray.


And what happens if you add a single icon to that dock (doesn't matter what, just add something) ?

_________________
Jorge Coelho
Winstep Xtreme - Xtreme Power!
http://www.winstep.net - Winstep Software Technologies


Back to top
 Profile WWW 
 
 Post subject: Re: Odd Focus Toggle Problem
PostPosted: Tue Jun 12, 2018 3:46 pm 
Offline
User avatar

Joined: Wed Mar 28, 2018 10:20 pm
Posts: 9
Location: Planet Earth
I tried adding the control icon, a module, and a launch icon, but no difference. If I disable "Grab Focus" it simply will not activate at all.

I also find it odd that this dock also ignores the disabled "bring dock forward" settings, but that's another issue.
Attachment:
SS.1528818241.png
SS.1528818241.png [ 31.4 KiB | Viewed 1553 times ]

_________________
"There's no such thing as a foolproof system. Someone will make a better fool, tomorrow." —LoneWolffe


Back to top
 Profile WWW 
 
 Post subject: Re: Odd Focus Toggle Problem
PostPosted: Tue Jun 12, 2018 5:15 pm 
Offline
Site Admin
User avatar

Joined: Thu Feb 26, 2004 8:30 pm
Posts: 9867
Weeeeird. Can you please also post a screenshot of the Position tab for that dock?

_________________
Jorge Coelho
Winstep Xtreme - Xtreme Power!
http://www.winstep.net - Winstep Software Technologies


Back to top
 Profile WWW 
 
 Post subject: Re: Odd Focus Toggle Problem
PostPosted: Tue Jun 12, 2018 11:20 pm 
Offline
User avatar

Joined: Wed Mar 28, 2018 10:20 pm
Posts: 9
Location: Planet Earth
IKR? I'm dumbfounded:
Attachment:
SS.1528845576.png
SS.1528845576.png [ 42.82 KiB | Viewed 1546 times ]

_________________
"There's no such thing as a foolproof system. Someone will make a better fool, tomorrow." —LoneWolffe


Back to top
 Profile WWW 
 
 Post subject: Re: Odd Focus Toggle Problem
PostPosted: Tue Jun 12, 2018 11:44 pm 
Offline
Site Admin
User avatar

Joined: Thu Feb 26, 2004 8:30 pm
Posts: 9867
Have you tried docking it to another screen edge already?

Anyway, something completely unrelated I noticed in your screenshots: automatically using the Windows 10 accent color for bitmaps and section titles in Preference screens doesn't always look that good. Guess I need to add an optional way to set the accent color Preferences will use.

_________________
Jorge Coelho
Winstep Xtreme - Xtreme Power!
http://www.winstep.net - Winstep Software Technologies


Back to top
 Profile WWW 
 
 Post subject: Re: Odd Focus Toggle Problem
PostPosted: Wed Jun 13, 2018 12:53 am 
Offline
User avatar

Joined: Wed Mar 28, 2018 10:20 pm
Posts: 9
Location: Planet Earth
Ok, I gave your suggestion a try, docking to the top instead of docking to the right. It was the same. No matter what activation settings I use, disabling grab focus prevents it from activating. Do you think it's because I have three docks? Is there a log I can share with you to help you with this?

Also, regarding your other comment, are you talking about a setting or something in the UI?

_________________
"There's no such thing as a foolproof system. Someone will make a better fool, tomorrow." —LoneWolffe


Back to top
 Profile WWW 
 
 Post subject: Re: Odd Focus Toggle Problem
PostPosted: Wed Jun 13, 2018 1:49 pm 
Offline
Site Admin
User avatar

Joined: Thu Feb 26, 2004 8:30 pm
Posts: 9867
bnjroo wrote:
Ok, I gave your suggestion a try, docking to the top instead of docking to the right. It was the same. No matter what activation settings I use, disabling grab focus prevents it from activating. Do you think it's because I have three docks? Is there a log I can share with you to help you with this?


Let me see if I can reproduce the problem here first. As you are probably aware I am currently very busy adding multiple shelves, etc, and there have been so many changes to the existing code because of this that things are still in a bit of turmoil.

I don't see any reason why a third dock would behave any different from the others... unless... unless we are looking in the wrong place.

What happens if you disable (disable, NOT delete, eheh) the other two docks?

bnjroo wrote:
Also, regarding your other comment, are you talking about a setting or something in the UI?


As you can see in the screenshots above, under Windows 10 when Dark Mode is enabled, the Winstep application use will the current Windows 'accent color' (the color used for the title bars of windows, etc) to colorize the section titles and those 'Information' and 'Warning' bitmaps in the UI.

Unfortunately this does not work well with all colors (in your case, it's too dark, IMO). So, you can select a cool accent color for the title bars of windows and that color look really bad when used in the UI.

The solution would be for me to add an option to manually select a color to be used in the UI, instead of *always* using the current Windows accent color.

_________________
Jorge Coelho
Winstep Xtreme - Xtreme Power!
http://www.winstep.net - Winstep Software Technologies


Back to top
 Profile WWW 
 
 Post subject: Re: Odd Focus Toggle Problem
PostPosted: Wed Jun 13, 2018 2:00 pm 
Offline
User avatar

Joined: Wed Mar 28, 2018 10:20 pm
Posts: 9
Location: Planet Earth
Yes, I see what you mean regarding the accent color. Regarding the activation problem, I disabled the other docks and shelf, but the problem remains. I was trying to add the file, but it says extension not allowed. Here's a link to the file on Drive: https://drive.google.com/open?id=1N5Ond ... tNa0wK85wp

_________________
"There's no such thing as a foolproof system. Someone will make a better fool, tomorrow." —LoneWolffe


Back to top
 Profile WWW 
 
 Post subject: Re: Odd Focus Toggle Problem
PostPosted: Thu Aug 02, 2018 12:32 am 
Offline
Site Admin
User avatar

Joined: Thu Feb 26, 2004 8:30 pm
Posts: 9867
Try the beta of v18.8, see if that solves the problem by any chance.

_________________
Jorge Coelho
Winstep Xtreme - Xtreme Power!
http://www.winstep.net - Winstep Software Technologies


Back to top
 Profile WWW 
 
 Post subject: Re: Odd Focus Toggle Problem
PostPosted: Thu Aug 02, 2018 1:43 am 
Offline
User avatar

Joined: Wed Mar 28, 2018 10:20 pm
Posts: 9
Location: Planet Earth
winstep wrote:
Try the beta of v18.8, see if that solves the problem by any chance.


OSM! 8) It works perfectly. I disabled "Grab Focus on Activation" and now that pesky toolbar opens on edge bump without a problem.

Think you could work in the focus toggle on the shelf, too? :D

_________________
"There's no such thing as a foolproof system. Someone will make a better fool, tomorrow." —LoneWolffe


Back to top
 Profile WWW 
 
Post new topic Reply to topic Board index : Winstep Forums : General Discussion  [ 13 posts ]
Display posts from previous:  Sort by  

Who is online

Users browsing this forum: Google [Bot] and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: