Winstep Forums
http://forums.winstep.net/phpBB2/

Icons in the Drives tab of the Shelf
http://forums.winstep.net/phpBB2/viewtopic.php?f=2&t=10815
Page 1 of 1

Author:  oOSGearOo [ Mon Sep 17, 2018 1:13 pm ]
Post subject:  Icons in the Drives tab of the Shelf

winstep wrote:
Thanks!

Just download and install the latest version, provided your license key still works with it (remember, 1 year of free updates, after that you need to renew).

How many licences do I need?
I have one pc at home with Winstep xstream, I also attend UNI and have a virtual machine there also. Will one licence cover the two installs? Currently the main pc at home has the licence applied.

On another topic can I join the Beta forums please. I have applied but no joy yet, I know you say to wait, so I am doing my best to wait patiently.



--
Stephen

Author:  winstep [ Mon Sep 17, 2018 9:40 pm ]
Post subject:  Re: Icons in the Drives tab of the Shelf

I've split this post into it's own topic.

oOSGearOo wrote:
On another topic can I join the Beta forums please. I have applied but no joy yet, I know you say to wait, so I am doing my best to wait patiently.


I can grant you access, but the Beta section of the forums is pretty much dead since I moved beta discussion into the General section of the forums (See the 'So, what's next after v18.8?' thread)

oOSGearOo wrote:


I've actually seen this happen myself too. Seems specific to the Drives tab *and* to Windows 10. I have to look further into this to try and figure out the cause.

As for your other question, I'll send you a PM.

Author:  oOSGearOo [ Mon Sep 17, 2018 10:54 pm ]
Post subject:  Re: Icons in the Drives tab of the Shelf

Yes mostly confined to the "Drives" tab, although I have one other "Control Panel" ->"power options"

Please note that this happens, not the first time but after several attempts, at dipping into the shelf "Drives" Tab. Then it appears over and over once its started.
--
Stephen

Author:  winstep [ Mon Sep 17, 2018 11:08 pm ]
Post subject:  Re: Icons in the Drives tab of the Shelf

If you look carefully, you'll see that a question mark icon also appears at the top left of the Shelf.

I thought I had worked around this already. It seems to be somehow related to an interrupt happening when it should not (that is, particular sections of the code are designed to run from start to finish without interruption, but apparently when retrieving some icons something outside of the Winstep application related to this causes an interrupt to happen in the middle of such a section, which in turn makes other sections of Winstep code run when they were only supposed to run AFTER completion of the other section, with unpredictable results).

So, it's not a bug on the Winstep application per se, but Windows causing something to happen which was not supposed to happen in the first place.

The joys of computers and operating systems.

Author:  oOSGearOo [ Wed Oct 10, 2018 4:21 am ]
Post subject:  Re: Icons in the Drives tab of the Shelf

oOSGearOo wrote:
Yes mostly confined to the "Drives" tab, although I have one other "Control Panel" ->"power options"

--
Stephen

I have still this problem It is the "Power options" in a new "control panel" tab of the shelf.
Attachment:
Capture1.PNG
Capture1.PNG [ 39.29 KiB | Viewed 2602 times ]


:Edit Its permentaly stuck though, none of the hideing and showing off the first video post.

Author:  winstep [ Wed Oct 10, 2018 6:02 am ]
Post subject:  Re: Icons in the Drives tab of the Shelf

oOSGearOo wrote:
I have still this problem It is the "Power options" in a new "control panel" tab of the shelf.
:Edit Its permentaly stuck though, none of the hideing and showing off the first video post.


Exactly. Very different issue from the previous one.

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/