Winstep

Software Technologies


 Winstep Forums


Print view
Board index : Winstep Forums : General Discussion  [ 17 posts ] Go to page 1, 2  Next
Author Message
 Post subject: Fast Boot Challenges
PostPosted: Tue Mar 05, 2019 3:34 pm 
Offline

Joined: Mon Mar 04, 2019 8:23 pm
Posts: 13
Dear Jorge and the Wonderful Contributors to the Winstep Forums,

I have encountered a challenge using Fast Boot with Winstep Xtreme on my Windows 10 computer. After initially choosing to activate Fast Boot, things worked fine, but after rebooting my computer the beneficial effect disappeared and there was still the delay in activating your great utility.

Looking at the Windows registry (which I am very used to doing), I noticed that the entry "RunOnce" was followed by an entry "RunOnce-Disabled". So I deleted that second entry.

Then I looked on the Winstep Forums and manually tried to activate Fast Boot using a .REG file I created:
REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\RunOnce]
"Winstep SpeedLaunch"="C:\\Program Files (x86)\\Winstep\\winstep.exe /speedlaunch"

When I logged off and then logged on again, it worked fine, but then every time I reboot or restart the computer that entry is completely deleted and I do not get the advantage of Fast Boot.

Can you help? Clearly something else is preventing this registry key from staying. My only optimization utility running in the background is System Mechanic, and I tried uninstalling/disabling that and there was no change.

Thanks so much for anything you can suggest!


Back to top
 Profile  
 
 Post subject: Re: Fast Boot Challenges
PostPosted: Tue Mar 05, 2019 6:49 pm 
Offline

Joined: Fri Sep 14, 2018 6:42 pm
Posts: 140
Hi
For what its worth just rebooted this machine and fastboot did NOT run.
Iam not so used to digging around in the registry.

A couple of other things are missing a network share and so on.

Investigating.

_________________
oOSGearOo Aka Steve....
http://technobable.com
https://www.technobable.com/uncategoriz ... p-extreme/


Back to top
 Profile  
 
 Post subject: Re: Fast Boot Challenges
PostPosted: Tue Mar 05, 2019 7:19 pm 
Offline

Joined: Mon Mar 04, 2019 8:23 pm
Posts: 13
Dear oOSGearOo,

Thanks SO much for looking into this! I am eager to hear what you or anyone else finds that might be helpful here....


Back to top
 Profile  
 
 Post subject: Re: Fast Boot Challenges
PostPosted: Tue Mar 05, 2019 8:56 pm 
Offline
Site Admin
User avatar

Joined: Thu Feb 26, 2004 8:30 pm
Posts: 10483
Ok, first off, you should NOT dig around in the Registry, as 'guessing' can sometimes make it worse. Let the application do its thing. :)

That key is not supposed to stay, in fact it won't stay as it is automatically deleted by Windows (as it should). The application re-applies it afterwards when it runs though.

Anyway, I run my system 24/7 and I rarely reboot it, which makes any Fast Boot failures very hard to be noticed by me. This said, every time you reboot the Winstep Fast Boot feature writes a small log to

C:\Users\Public\Documents\WinStep\FastBoot.Log

Open the file in a text editor and paste back what is inside.

_________________
Jorge Coelho
Winstep Xtreme - Xtreme Power!
http://www.winstep.net - Winstep Software Technologies


Back to top
 Profile WWW 
 
 Post subject: Re: Fast Boot Challenges
PostPosted: Tue Mar 05, 2019 9:35 pm 
Offline

Joined: Mon Mar 04, 2019 8:23 pm
Posts: 13
Dear Jorge,

Thanks for your quick and helpful reply! I will get you that log file tomorrow, for I am at work now and not at my home computer.

I am very experienced working around the registry, and always make a backup before I do anything. Nonetheless, your warning is very prudent.

The only reason I took this route was because Fast Boot was not sticking after a reboot (I reboot all the time). I apologize if it was the wrong thing to do--I probably just have gone directly to the WinStep forum experts.

I really appreciate your attention, and will get you that file tomorrow morning....


Back to top
 Profile  
 
 Post subject: Re: Fast Boot Challenges
PostPosted: Tue Mar 05, 2019 9:52 pm 
Offline

Joined: Fri Sep 14, 2018 6:42 pm
Posts: 140
Hi Jorge mine is back to normal the files says.

"
0\7\0\00
"

Hopping that's normal.

_________________
oOSGearOo Aka Steve....
http://technobable.com
https://www.technobable.com/uncategoriz ... p-extreme/


Back to top
 Profile  
 
 Post subject: Re: Fast Boot Challenges
PostPosted: Wed Mar 06, 2019 3:16 pm 
Offline

Joined: Mon Mar 04, 2019 8:23 pm
Posts: 13
Dear Jorge,

The contents of the log file is as follows:
12\7\0\00

Thanks for your time!


Back to top
 Profile  
 
 Post subject: Re: Fast Boot Challenges
PostPosted: Wed Mar 06, 2019 9:15 pm 
Offline
Site Admin
User avatar

Joined: Thu Feb 26, 2004 8:30 pm
Posts: 10483
Each of the numbers represents a specific application (NextSTART/WorkShelf/Ultimate/Nexus). A value of 0 means it's not running (for instance, in oOSGearOo's case the first 0 means he has NextSTART set NOT to run at Startup).

A value of 7 means FastBoot has succeeded. Any other number means something went wrong, and the value allows me to know what step failed.

In your case, BobMand, WorkShelf was successfully speed-launched (7) but apparently not NextSTART (12).

The way Winstep's fast boot works is complicated, not so much because you need to bypass Windows deliberate delay imposed on 3rd party applications (that is the easy part) but because you need to launch the applications with NORMAL privileges and NOT elevated (this is the more complicated part and where things can go wrong).

For the latter to suceed, Explorer must already be running. Since so much is happening at startup, in theory it's possible for Explorer not to be in a ready state when the Winstep launcher runs, and apparently that's what happened in this particular case. It seems to me this is more of a 'race condition' than anything else.

Either way, whenever the application runs it puts the necessary values back into the HKLM RunOnce key in the Registry, which is why you should NOT interfere with this by editing the Registry directly.

To be able to write to HKLM the Winstep service MUST be running - if you disabled that (some people like to tinker with stuff despite not knowing what they are doing and so they disable the service) then the Fast Boot mechanism (among other actions that require admin privileges) will also fail.

_________________
Jorge Coelho
Winstep Xtreme - Xtreme Power!
http://www.winstep.net - Winstep Software Technologies


Back to top
 Profile WWW 
 
 Post subject: Re: Fast Boot Challenges
PostPosted: Wed Mar 06, 2019 9:34 pm 
Offline

Joined: Mon Mar 04, 2019 8:23 pm
Posts: 13
Dear Jorge,

Thanks for your helpful response!

I did not disable the Winstep service. Is there any way that I can check in the registry (or elsewhere) to see if the Winstep service somehow got deactivated inadvertently (possibly through third-party utilities) and reactivate it?

I have a lot of extra stuff loading when my computer boots into Windows, so is it possible that, as you suggested, Explorer is not be in a ready state when the Winstep launcher runs? Do I need to address that too?

Given the clues you have provided, I want to fix the problem and get Fast Boot working, and I sure appreciate any help you can provide.

Thanks so much again!


Back to top
 Profile  
 
 Post subject: Re: Fast Boot Challenges
PostPosted: Wed Mar 06, 2019 10:56 pm 
Offline
Site Admin
User avatar

Joined: Thu Feb 26, 2004 8:30 pm
Posts: 10483
Windows Control Panel -> Administrative Tools -> Services

See if the Winstep Xtreme Service is running. It should be, otherwise you would not even get the FastBoot.log file.

Anyway, delete the log file, reboot, and see what the FastLog.log file says this time.

_________________
Jorge Coelho
Winstep Xtreme - Xtreme Power!
http://www.winstep.net - Winstep Software Technologies


Back to top
 Profile WWW 
 
 Post subject: Re: Fast Boot Challenges
PostPosted: Wed Mar 06, 2019 11:05 pm 
Offline

Joined: Mon Mar 04, 2019 8:23 pm
Posts: 13
Thanks SO MUCH!!!!!!!!!!!!!!!!!

I will do this tonight and get back to you tomorrow....


Back to top
 Profile  
 
 Post subject: Re: Fast Boot Challenges
PostPosted: Thu Mar 07, 2019 3:48 pm 
Offline

Joined: Mon Mar 04, 2019 8:23 pm
Posts: 13
Dear Jorge,

Last night I checked and discovered by looking at the Control Panel as you suggested that Winstep Xtreme Service was indeed NOT running--it was not listed on the Services list at all.

I then as you suggested went ahead and deleted the Fast Boot log file, and then after a reboot no new log file emerged to replace it.

I think I know what happened here. The ONLY thing I did with the registry was what I reported--create that .reg file to try to manually get Fast Boot to run. BUT during the previous week I was trying out some alternatives for Windows optimization software--experimenting with their cleanup options--and I bet one disabled Winstep Xtreme Service without me knowing about it. Sorry about that--I will try to be more careful in the future.

In any case, is there a way to re-enable Winstep Xtreme Service? I am hoping that you do not say that I have to completely uninstall and reinstall Winstep Xtreme, for I have spent hours and hours customizing everything just the way I like it (thanks to the wonderful array of customization options you provided). And somehow even without Winstep Xtreme Service everything (Workshelf, NextSTART, and the modules) is working perfectly (except of course for Fast Boot)....

Thanks again for everything!!!!!!!!!!!!!!!


Back to top
 Profile  
 
 Post subject: Re: Fast Boot Challenges
PostPosted: Thu Mar 07, 2019 4:04 pm 
Offline
Site Admin
User avatar

Joined: Thu Feb 26, 2004 8:30 pm
Posts: 10483
Just re-install the full version of Winstep Xtreme *on top*. No need to uninstall anything first and your settings will be preserved (but you can always make a backup first if it makes you feel better).

Just remember to exit Winstep Xtreme before running setup.

_________________
Jorge Coelho
Winstep Xtreme - Xtreme Power!
http://www.winstep.net - Winstep Software Technologies


Back to top
 Profile WWW 
 
 Post subject: Re: Fast Boot Challenges
PostPosted: Thu Mar 07, 2019 4:07 pm 
Offline

Joined: Tue Mar 01, 2016 11:46 am
Posts: 403
you can backup/export your settings (complete with docks,shelves and everything) from preferences-advanced
just need to backup seperately for workshelf/docks and nextstart since they are separate apps


Back to top
 Profile  
 
 Post subject: Re: Fast Boot Challenges
PostPosted: Thu Mar 07, 2019 4:08 pm 
Offline

Joined: Mon Mar 04, 2019 8:23 pm
Posts: 13
Dear Jorge,

Will do!!!!!! And thanks SO MUCH again....

I will report back tomorrow about the results....


Back to top
 Profile  
 
Post new topic Reply to topic Board index : Winstep Forums : General Discussion  [ 17 posts ] Go to page 1, 2  Next
Display posts from previous:  Sort by  

Who is online

Users browsing this forum: No registered users and 17 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: