Winstep

Software Technologies


 Winstep Forums


Print view
Board index : Winstep Forums : General Discussion  [ 6 posts ]
Author Message
 Post subject: Drag and Drop Bug
PostPosted: Sun Apr 26, 2020 11:56 am 
Offline

Joined: Wed Aug 05, 2009 3:47 pm
Posts: 811
Hi Jorge, found a problem with one of my favorite features yesterday. It took me a long time to figure out why some videos I DL wouldn't drop.

I tested it using only Windows via QTTabBar and the videos moved to the new location.

When I tried to drag and drop the file(s) to be moved to another drive using the dock, nothing. To further test it, I tried to drag said files into a folder via bumping a hotspot that brings up the context menu with my folders and nothing.

The problem, the files all had @ in the file name. When I deleted the @, the files dropped with no problem to the dock and using the hotspot bump > context menu for my folders.

I'm using Xtreme version 19.4


Back to top
 Profile  
 
 Post subject: Re: Drag and Drop Bug
PostPosted: Sun Apr 26, 2020 3:42 pm 
Offline
Site Admin
User avatar

Joined: Thu Feb 26, 2004 8:30 pm
Posts: 10928
Windy, we have been through exactly this years ago, when you complained that copying many files to a tab in the Shelf blocked the Winstep application until the copy operation completed, remember?

Upon your request, I made sure that when there are many files to copy the operation is actually performed asynchronously by winstep.exe instead, so the main application does not block.

This means that some characters are reserved and cannot be used in the filename as they are used as filename separators when passing information to winstep.exe, @ being one of those characters IIRC.

_________________
Jorge Coelho
Winstep Xtreme - Xtreme Power!
http://www.winstep.net - Winstep Software Technologies


Back to top
 Profile WWW 
 
 Post subject: Re: Drag and Drop Bug
PostPosted: Sun Apr 26, 2020 4:54 pm 
Offline

Joined: Wed Aug 05, 2009 3:47 pm
Posts: 811
Yes I remember that.

I didn't know that preventing files with @ had something to do with fixing the multiple files transfer issue, especially since the files move/transfer using Windows.

I know there are certain characters that aren't allowed in Windows and if a prohibited character is used when changing a file name, Windows automatically deletes that character.

I assumed that Winstep must follow the same disallowed character rules as Windows for the files to transfer, so since the @ doesn't transfer, I figured it was a bug.


Back to top
 Profile  
 
 Post subject: Re: Drag and Drop Bug
PostPosted: Sun Apr 26, 2020 6:36 pm 
Offline
User avatar

Joined: Thu Mar 18, 2004 12:11 am
Posts: 397
Location: Pollock Pines, CA
Windy wrote:
I know there are certain characters that aren't allowed in Windows and if a prohibited character is used when changing a file name, Windows automatically deletes that character.


I have noticed lately that Windoze 10 sometimes allows a reserved character in a file name and then places an extra file in that folder to make that happen (the extra file is apparently how Windoze keeps track of the ACTUAL file name, since the actual file name can't contain reserved characters). I have no idea how I manage to get the reserved characters in the file name because I have tried to copy part of an existing file's file name (containing a ":") to a new file and it wouldn't let me use the ":" in the new file name even though I copied it from another file's file name.

A little history: when I name a file for a movie that is part of a series, for instance, I use ":" after the series name before the particular episode. You will notice that I don't use ":" (colon), I use ":" (fullwidth colon) because colon ":" is a reserved character and the fullwidth colon ":" is not. Somehow, Windowze 10 has sometimes changed the fullwidth colon I used in a file name to a standard colon character, even though that is a reserved character and not allowed in file names. I have no idea how it happens, but it sometimes does happen, but then Windoze won't let me duplicate it.

_________________
vectornut
http://www.vectornut.com


Back to top
 Profile WWW 
 
 Post subject: Re: Drag and Drop Bug
PostPosted: Mon Apr 27, 2020 4:12 am 
Offline

Joined: Wed Aug 05, 2009 3:47 pm
Posts: 811
I wasn't aware of the fullwidth colon. My solution was to either use a semicolon ; or nothing at all. I looked it up and found some info on it. I found a page that has it copied. https://stackoverflow.com/questions/103 ... e-filename To my amazement, if I paste it into Notepad++ for further use, it will not work.

Maybe I would have to change a setting in Notepad++ for it to work. I only use Notepad++ to list videos and links because it's much better than using regular Notepad or even Libre Office for that.

I pasted it into Libre Office and it works for further use. However, I probably won't use it because it aesthetically bugs me that it will not allow you to remove the space BEFORE the symbol.

For example, if I add it to a video's file name, VLC will display the filename with spaces on either side of the symbol even though the symbol is physically right up against the text.

Although removing the space AFTER the symbol cannot be done either, that doesn't bother me since it's supposed to have at least one space after it.


Back to top
 Profile  
 
 Post subject: Re: Drag and Drop Bug
PostPosted: Wed Apr 29, 2020 2:53 am 
Offline
User avatar

Joined: Thu Mar 18, 2004 12:11 am
Posts: 397
Location: Pollock Pines, CA
Windy wrote:
. . . I probably won't use it because it aesthetically bugs me that it will not allow you to remove the space BEFORE the symbol.

For example, if I add it to a video's file name, VLC will display the filename with spaces on either side of the symbol even though the symbol is physically right up against the text.

Although removing the space AFTER the symbol cannot be done either, that doesn't bother me since it's supposed to have at least one space after it.


When I use it for a file name, I don't use it in the ID3 tag or whatever. That said, when I stumbled across it, I hadn't seen these:

https://unicode-search.net/unicode-name ... term=COLON

These look normal but work in a file name: "ː" or "∶"

_________________
vectornut
http://www.vectornut.com


Back to top
 Profile WWW 
 
Post new topic Reply to topic Board index : Winstep Forums : General Discussion  [ 6 posts ]
Display posts from previous:  Sort by  

Who is online

Users browsing this forum: Google [Bot] and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: