Winstep

Software Technologies


 Winstep Forums


Print view
Board index : Winstep Forums : General Discussion  [ 5 posts ]
Author Message
 Post subject: When I open Sub-dock the icons are gone
PostPosted: Sun Jan 23, 2022 10:30 pm 
Offline

Joined: Sat Jan 08, 2022 4:51 am
Posts: 6
Hi everyone, I have Nexus ultimate I have created a Sub-Dock and there are folders inside how come when I go to open that sub-dock the folders have no icons? after 1/2 seconds the icons load and I can see them.
I tried to set the icons in both .png and .ico format but it always does this.

is there a solution to this?

https://imgur.com/SIkhiz6

thank you


Back to top
 Profile  
 
 Post subject: Re: When I open Sub-dock the icons are gone
PostPosted: Mon Jan 24, 2022 12:19 am 
Offline
Site Admin
Site Admin
User avatar

Joined: Thu Feb 26, 2004 8:30 pm
Posts: 11376
What version of Nexus Ultimate are you running?

Sub-docks, unlike Shelves, Drawers and main docks, do NOT cache icons in memory. As such, these icons need to be retrieved from disk every time the sub-dock is opened.

If the sub-dock notices that it is taking too long to retrieve all the icons (i.e.; 1 second or more) then it prioritizes keeping the application responsive (so you don't click on the sub-dock icon and nothing happens for a long time). It will thus render the icons it has already fetched in that 1 second time limit and use a generic icon for the remaining items - once the sub-dock is fully open it will then 'lazy render' the remaining icons one by one.

Again, the priority is to keep the application responsive even if certain items are located on slow storage or in a network drive.

And this is usually the problem: one of those items in the sub-dock (and it will be one of the items that gets the icons rendered first time) - or the icon/image file used for that item - is located either in a very very slow hard disk OR not in local storage.

Not sure if that is the case, but it's not recommended to put items that are located on network drives on docks, precisely because it can sometimes take a long time to retrieve that item's icon.

_________________
Jorge Coelho
Winstep Xtreme - Xtreme Power!
http://www.winstep.net - Winstep Software Technologies


Back to top
 Profile WWW 
 
 Post subject: Re: When I open Sub-dock the icons are gone
PostPosted: Mon Jan 24, 2022 6:16 pm 
Offline

Joined: Sat Jan 08, 2022 4:51 am
Posts: 6
i am using this version:
Image

but the folders I have in that Sub-dock are in a hard drive connected directly to the computer they are not network folders.

it's strange because this thing is the first time in all these years of using nexsus (I used the free version also never had this problem)


Back to top
 Profile  
 
 Post subject: Re: When I open Sub-dock the icons are gone
PostPosted: Mon Jan 24, 2022 7:11 pm 
Offline
Site Admin
Site Admin
User avatar

Joined: Thu Feb 26, 2004 8:30 pm
Posts: 11376
Try removing the icons from the sub-dock (by temporarily dragging them to the main dock, for instance) and then adding them again one by one randomly to see if there is an item in particular that might be causing the delay.

To be safe, before doing this you can always backup your settings first: Preferences -> Advanced tab -> Backup button.

Also, the icons used for the folders in the sub-dock, what happens if you use the actual folder icons (i.e.; leave the Icon Path field blank for each item in the dock)?

A bit of trial and error might help clarify what is happening there.

_________________
Jorge Coelho
Winstep Xtreme - Xtreme Power!
http://www.winstep.net - Winstep Software Technologies


Back to top
 Profile WWW 
 
 Post subject: Re: When I open Sub-dock the icons are gone
PostPosted: Tue Jan 25, 2022 6:18 pm 
Offline

Joined: Sat Jan 08, 2022 4:51 am
Posts: 6
I tried copying the icons to drive C and it works fine for now.

Thanks anyway for the support
greetings from Italy


Back to top
 Profile  
 
Post new topic Reply to topic Board index : Winstep Forums : General Discussion  [ 5 posts ]
Display posts from previous:  Sort by  

Who is online

Users browsing this forum: Majestic-12 [Bot] and 29 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: