Winstep Forums
https://forums.winstep.net/phpBB2/

"Elevated privileges" and UAC issue, after update
https://forums.winstep.net/phpBB2/viewtopic.php?f=2&t=10557
Page 1 of 2

Author:  shoppi [ Mon Dec 04, 2017 7:20 am ]
Post subject:  "Elevated privileges" and UAC issue, after update

After a very recent update to Winstep Xtreme 17.1, it offers, on startup, an error message as attached.

It appears to be linked to the Workshelf element of the program.

UAC is off. I have not changed privileges. I have checked that "run as administrator" is off for the different elements of Xtreme, Workshelf included. Under Properties > Security for each constituent application, "Users" have full permissions.

Windows 10, version 1703, build 15063.726.

Is this a bug?

I'd be really pleased if someone could address this. Thanks.

Attachments:
2017_12_04 08-14-36.png
2017_12_04 08-14-36.png [ 16.58 KiB | Viewed 5961 times ]

Author:  winstep [ Mon Dec 04, 2017 7:26 am ]
Post subject:  Re: "Elevated privileges" and UAC issue, after update

shoppi wrote:
Is this a bug?


It's not a bug: WorkShelf cannot elevate itself.

This said, what happens if you exit WorkShelf and manually launch it again? Same message?

Also, is the 'Fast boot' option enabled (WorkShelf Preferences -> General tab -> WorkShelf section)? If so, try disabling it and reboot.

Author:  shoppi [ Mon Dec 04, 2017 7:56 am ]
Post subject:  Re: "Elevated privileges" and UAC issue, after update

Thanks for the quick response.

When I rebooted computer this morning, and started Nextstart and Workshelf individually and manually, and in that order, the problem was still there.

And, no, Fast Boot is disabled.

If I go into Workshelf > Properties > Security, permissions are as per the attached screengrabs (could only upload 3 of the 5).

For Admins, everything except Special Permissions is allowed, and nothing denied. For Users, the same.

Have I got them set right?

Attachments:
2017_12_04 08-47-04.png
2017_12_04 08-47-04.png [ 22.33 KiB | Viewed 5958 times ]
2017_12_04 08-46-47.png
2017_12_04 08-46-47.png [ 23.44 KiB | Viewed 5958 times ]
2017_12_04 08-46-33.png
2017_12_04 08-46-33.png [ 23.72 KiB | Viewed 5958 times ]

Author:  winstep [ Mon Dec 04, 2017 8:23 am ]
Post subject:  Re: "Elevated privileges" and UAC issue, after update

shoppi wrote:
For Admins, everything except Special Permissions is allowed, and nothing denied. For Users, the same. Have I got them set right?


No, that is wrong. Under my Windows 10 system the Users group for the WorkShelf executable only has the 'Read' and 'Read and Execute' rights enabled.

Author:  shoppi [ Mon Dec 04, 2017 8:37 am ]
Post subject:  Re: "Elevated privileges" and UAC issue, after update

Thanks. System won't let me change permissions for Users for Workshelf. It's either Allow on everything, or Deny on everything. Not sure why.

Not sure what to do next. Any ideas?

Author:  winstep [ Mon Dec 04, 2017 8:51 am ]
Post subject:  Re: "Elevated privileges" and UAC issue, after update

Permissions in Windows are a complicated matter lol. Try Googling about it.

Also, are you logged in as Admin or just as a normal user?

Author:  shoppi [ Mon Dec 04, 2017 9:05 am ]
Post subject:  Re: "Elevated privileges" and UAC issue, after update

Admin. I'll search. I think I can live with this, if necessary: things are set up as I like, and I'll just dismiss the nag screen when I start the program. Thanks for your time and efforts.

Author:  winstep [ Mon Dec 04, 2017 9:10 am ]
Post subject:  Re: "Elevated privileges" and UAC issue, after update

Sorry I can't help further, I'm not an expert on Windows security either. :)

However, I would NOT run it like this, not in a million years: it is a HUGE security risk - *anything* you launch from an elevated application also runs elevated. You will get your system p0wned in no time at all.

Author:  shoppi [ Mon Dec 04, 2017 9:14 am ]
Post subject:  Re: "Elevated privileges" and UAC issue, after update

Thanks. Noted. I'll search for a fix!

Author:  winstep [ Mon Dec 04, 2017 9:17 am ]
Post subject:  Re: "Elevated privileges" and UAC issue, after update

Let me know if you find a solution - and also if you figure out what caused this. Have you tried looking up other application's executables security rights? Could be an issue with the Users group itself, not with a particular executable.

Also, what happens when you log in to Windows as a regular user instead of Admin?

Author:  shoppi [ Mon Dec 04, 2017 9:32 am ]
Post subject:  Re: "Elevated privileges" and UAC issue, after update

Under Workshelf > Properties > Security > Advanced, I disinherited Users, and Users is now down to Read & Execute, and Read, only.

Same with All Application Packages and All Restricted Application Packages.

System has full permissions, as do Administrators.

And yet I'm still getting the same flag.

I am comforted, however, by the fact that I have limited user permissions.

I'll see whether this resolves when I do a system reboot, later in the day.

Author:  shoppi [ Mon Dec 04, 2017 9:35 am ]
Post subject:  Re: "Elevated privileges" and UAC issue, after update

Though the flag is about Workshelf alone, I did wonder whether I should do the same disinheritance process/permission lowering for the other .exe applications in the Winstep folder. Thoughts?

Author:  winstep [ Mon Dec 04, 2017 10:32 am ]
Post subject:  Re: "Elevated privileges" and UAC issue, after update

I wouldn't do anything until I understood what caused the problem in the first place. You can seriously hose your system if you start playing around with permissions without being absolutely sure of what you are doing.

Also, check out the permissions for winstep.exe. That is the application that launches NextSTART and WorkShelf at the same time. If winstep.exe is running elevated, then WorkShelf will also start elevated.

How are you running WorkShelf now? By double clicking the executable or the Winstep Xtreme shortcut? Also check the shortcut permissions.

Author:  shoppi [ Mon Dec 04, 2017 10:34 am ]
Post subject:  Re: "Elevated privileges" and UAC issue, after update

Yep. Thanks. I'll leave it where it is for the moment.

Author:  winstep [ Mon Dec 04, 2017 10:35 am ]
Post subject:  Re: "Elevated privileges" and UAC issue, after update

Sorry, I edited my reply with further suggestions, please read it again. You're too quick lol

Page 1 of 2 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/