Winstep

Software Technologies


 Winstep Forums


Print view
Board index : Winstep Forums : General Discussion  [ 8 posts ]
Author Message
 Post subject: How to disable losing window focus
PostPosted: Mon Sep 16, 2013 7:22 pm 
Offline

Joined: Wed Jan 04, 2012 11:36 am
Posts: 13
Hi,
I use Nexus Ultimate 12.2.
When I move cursor to the top of screen or to the any sides with the docks -- docks appear on screen and focus from active window switched on the any visible dock.
How to disable it? I want the docks appear only and set focus ONLY by mouse click

Sorry for my bad English :oops:


Back to top
 Profile  
 
 Post subject: Re: How to disable losing window focus
PostPosted: Fri May 12, 2017 11:50 am 
Offline
User avatar

Joined: Fri May 12, 2017 11:44 am
Posts: 4
Location: Spain
I just registered to ask for the exact same thing.

I have the dock on the right side of the window, and it's pretty annoying when you are scrolling manually in a maximized window and you move the cursor too far, so the dock gets the focus and you can't scroll anymore, you have to click the previous window to continue scrolling.

RocketDock's behaviour was better, the dock did became visible when this happened, but you didn't lose focus, so it wasn't a big deal.


Back to top
 Profile  
 
 Post subject: Re: How to disable losing window focus
PostPosted: Fri May 12, 2017 11:54 am 
Offline
Site Admin
User avatar

Joined: Thu Feb 26, 2004 8:30 pm
Posts: 8271
What version of Nexus are you running? Preferences -> About tab -> top right corner.

_________________
Jorge Coelho
Winstep Xtreme - Xtreme Power!
http://www.winstep.net - Winstep Software Technologies


Back to top
 Profile WWW 
 
 Post subject: Re: How to disable losing window focus
PostPosted: Fri May 12, 2017 11:56 am 
Offline
User avatar

Joined: Fri May 12, 2017 11:44 am
Posts: 4
Location: Spain
17.1


Back to top
 Profile  
 
 Post subject: Re: How to disable losing window focus
PostPosted: Fri May 12, 2017 12:33 pm 
Offline
Site Admin
User avatar

Joined: Thu Feb 26, 2004 8:30 pm
Posts: 8271
Since you mentioned a maximized window, I assume the dock is being activated by bumping the screen edge with the mouse pointer.

Although the dock does take the focus away when activated like that, it is also designed to automatically hide itself again - assuming auto-hide is enabled, of course - by simply moving the mouse pointer away from it - no need to click on anything.

_________________
Jorge Coelho
Winstep Xtreme - Xtreme Power!
http://www.winstep.net - Winstep Software Technologies


Back to top
 Profile WWW 
 
 Post subject: Re: How to disable losing window focus
PostPosted: Fri May 12, 2017 1:07 pm 
Offline
User avatar

Joined: Fri May 12, 2017 11:44 am
Posts: 4
Location: Spain
Yeah, but if you're holding the click because of manually scrolling, you don't get the focus back. It would be better if you only lose focus when clicking the dock.


Back to top
 Profile  
 
 Post subject: Re: How to disable losing window focus
PostPosted: Thu May 18, 2017 9:57 am 
Offline
User avatar

Joined: Fri May 12, 2017 11:44 am
Posts: 4
Location: Spain
Well, nevermind, I uninstalled it.


Back to top
 Profile  
 
 Post subject: Re: How to disable losing window focus
PostPosted: Thu May 18, 2017 12:26 pm 
Offline
Site Admin
User avatar

Joined: Thu Feb 26, 2004 8:30 pm
Posts: 8271
Your first post didn't specify that you were manually scrolling by holding the click (or at least it wasn't immediately obvious to me).

You do have a point, but I can't just 'fix' the problem by preventing the dock from getting the focus when you bump the screen edge without first making sure this won't break something else (such as drag & drop when the dock is hidden, for instance) - and that takes time.

Not the first time I applied a 'quick & easy fix' by request only to be bitten back with the unintended (and not immediately obvious) consequences of that fix - Nexus does a lot more than all the other docks do, and is actually a very complex application.

Since the scroll bar is on the far right side of the screen *and* we are talking about maximized windows here, you could have *probably* solved the problem by enabling the 'Ignore edge bumps near the titlebar button area of maximized windows' setting on the Edge Bump Settings dialog.

Sorry I didn't reply in time for you to try that out, got distracted by other things and ended up forgetting about your post.

_________________
Jorge Coelho
Winstep Xtreme - Xtreme Power!
http://www.winstep.net - Winstep Software Technologies


Back to top
 Profile WWW 
 
Post new topic Reply to topic Board index : Winstep Forums : General Discussion  [ 8 posts ]
Display posts from previous:  Sort by  

Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: